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Lab Report: lab 3 & lab4 combined

Lab schedule (Week 8, two Labs combined): 

     Two hour: Lab 4 TEB student Lab (Windows Environment)

     One hour: Lab 3  SEB UNIX Lab

LABORATORY 3

AND GATE/ADDER DESIGN USING VHDL AND SYNOPSYS
Preamble

The lab is divided into three parts. Parts I and II deal with VHDL simulation using the Synopsys VHDL System simulator (VSS). Part III focuses on logic synthesis; the Synopsys Design Compiler and Design Analyzer being the tools of choice. Design Compiler shell scripts have been used rather than the alternative Design Analyzer Graphical User Interface method of synthesizing a design. This conscious decision was based upon the convenience of shell scripts: they may be executed from the command line (obviating the need for a graphics workstation terminal) and they may readily modified for other designs. 

Prelab

Get familiar with the UNIX operating system (using text editors, copying files, creating directories, printing, etc.)
Part 1 Configuration
1.1 Synopsis Environment Configuration
1) Login to a Unix workstation
2) Copy .cshrc & and_gate.vhd & .aliases  file
ftp sun30 (log in with username:wwang password: wa.88.WA)

bin

get .cshrc

cd rumi
get and_gate.vhd
get.aliases (Skip this step if you took lab1&lab2 before)
bye

3) Set the synopsys environment variables (Skip this step if you took lab1 & lab2 before) : source .aliases
4) Set the synopsys environment variables:

source .cshrc

Deliverables:

1) Print the contents of the and_gate.vhd file.

Part 2: Design Analyzer

2.1  Invoke Synopsys

Invoke the Synopsys Design Analyzer with the following command issued from the UNIX prompt 

> design_analyzer & 

The Synopsys Design Analyzer will appear in a new window. 

From this window, Select Setup->Default. Change the setup of the libraries as:

Search path:             X03.06/libraries/syn     /CMC/tools/synopsys/syn_U-2003.06/CMC/cmosp18/syn      /CMC/kits/cmosp18/synopsys/2002/syn

Link library:            tpz973gwc.db  vst_n18_sc_tsm_c4_wc.db  *

Target Library:        tpz973gwc.db  vst_n18_sc_tsm_c4_wc.db

Symbol library:       null

2.2 Hierarchy Design

From this window, Select File -> Analyze. A new Analyze File window will appear. From this window, select and_gate.vhd from the file list and make sure that the File Format is set to VHDL. Select OK. 

Repeat the above steps given in  to analyze the full adder file. Note the order of analysis. 

From the Synopsys Design Analyzer window select File -> Elaborate. The Elaborate Design window will appear. Select Default from the list of libraries listed in the top part of the form. A list of designs will then appear. Select the circuit from the Design and select OK. 

Elaborate Design Window. The central portion of the Design Analyzer window will now contain one yellow squares. These icons correspond to the entities which were analyzed. Use the left mouse button to click on the icon and_gate.vhd. It will now be outlined with a dashed line. Select the down arrow button located on the bottom left hand side of the window; a new icon will appear in the central portion. There are four input ports labelled in_1 and in_2 on the left hand side and a single out-put port. This represents the symbol view of the entity and_gate. Left click on the button labelled with the symbol for an AND gate located third from the top on the left hand side of the Design Analyzer window. The top-level icon is now replaced with a schematic representation of the HDL code. Use the View -> Zoom In to zoom in. Select one of the blue wires (which reprsent signals) with the left mouse button. The corresponding signal name listed in the field named Net located at the bottom left hand corner of the window. 

Explore traversing the design hierarchy by selecting icon rectangle labelled and_gate or and then selecting the down arrow. The symbol for the and_gate entity is shown with the two input ports and single output port. This is the bottom of the hierarchy; it is not possible to descend further. Note that the down arrow key is shown as not selectable in the window. To go up in the hierarchy, use the up arrow key, this will return you to the and_gate entity. 

2.3   Logic Synthesis

From the main window, Select Setup -> command window.  The command window will appear.  In this window, type in 

Compile –map_effort high

You will get the logic synthesis results.  Then, type in

Report –area

You will get the area report.   Write down the cell number. Then type in

Report –timing

You will get the timing report.  Write down the rise time and fall time.
2.4 Optional

Try the full adder design following the above three setups.

 Deliverables 

1) Use File -> plot function, print the and_gate top level.

2) Write down the area and timing values of the and_gate.

Lab Report

Create a short report describing your activities.  The report should include the simulation results, listings of our simulation files, and printouts of your results that verify the correctness of your simulations.  Discuss our observations and comment on the results.

Note:  the students can use their printing quota (credit) to print the results in the lab.  Or they can save the results as PS file and print them at home.

Laboratory 4 
 Counter Design Using Xilinx Foundation Tools

Preamble

The Xilinx laboratory is divided into three parts. In Part I student learn how to use the Xilinx software and generate VHDL design flow project. Part II introduces the concepts of top level design.  In Part III students generate floor plan of their design.
Part 1: VHDL

In this section, you will create a 4-bit counter module using the Language Templates.  To do so, first create a new project and counter module, then modify the counter module with the counter template.

1.1 Starting the ISE Software

For PC users start ISE from the Start menu by selecting START ( Programs ( Xilinx ISE 5.x ( Project Navigator.

1.2 Creating a New Project

A project in ISE is a collection of all files necessary to create and download a design to the selected device.  To create a new project for this tutorial:

1. Select File ( New Project.

2. In the New Project dialog box, type the desired location in the Project Location field, or browse to the directory under which you want to create your new project directory using the browse button next to the Project Location field. (NOTE: USE “h:\Tutorial” for Project Location)
3. Enter “Tutorial” in the Project Name field. When you enter “Tutorial” in the Project Name field, a Tutorial subdirectory is automatically created in the directory path in the Project Location field.  For example, for the directory path D:\My_Projects entering the Project Name “Tutorial” modifies the path as D:\My_Projects\Tutorial.

4. Use the pull-down arrow to select the Value for each Property Name.  Click in the field to access the pull-down list. Change the values as follows:
(
Device Family: 
Virtex
(
Device:

xcv50
(
Package: 

bg256
(
Speed Grade:

-6
(
Design Flow:

XST VHDL
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5. Click OK
ISE creates and displays the new project in the Sources in Project window

1.3 Creating a Counter Module

Next, Create a VHDL module for a counter.  To create a counter module:


1. Select Project ( New Source.

2. Select VHDL Module as the source type.
3. Type in the file name “counter”.
4. Click Next.

5. Click Next.

6. Click Finish to complete the new source file template.


Counter.vhd, which is displayed in the HDL Editor window, contains the library declaration and use statements along with the empty entity and architecture pair for the counter you have just created.  HDL Editor is a text editor designed for editing HDL source files.
1.4 Modifying Counter Module with Counter Template

To complete the counter module, insert port declarations and the behavioral code for the VHDL counter from the ISE Language Templates.  The Language Templates contains many ABEL, Verilog and VHDL language templates for use in a design.

1. Open the Language Templates by selecting Edit ( Language Templates or by clicking the Language Templates icon located on the far right on the toolbar.
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Note: If the Language Template icon is not displayed in the toolbar, select View ( Editor Toolbar.


2. In the Language Templates window, click the “+” sign next to the VHDL to expand the hierarchy, then click the “+” sign next to Synthesis Templates, and select Counter.
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Templates: —- Required Libraries
--Llibrary IEEE;

--use IEEE.STD_LOGIC_1164.ALL;

--use IEEE.STD_LOGIC_UNSIGNED.ALL;

--use IEEE.STD_LOGIC_ARITH.ALL;

{2 Component Instantistion
{2 Language Templates

—- 4-bit synchronous counter with count enable,

(2 Syrthesis Templates - asynchronous reset and synchronous load
BarelShifer —- CLE: in STD_LOGIC;
Comparatar —- RESET: in STD_LOGIC;
e - CE, LOAD, DIR: in STD_LOGIC:
Debaunce cicuit - DIN: in STD_LOGIC_VECTOR(3 downto O} ;
Decoder - COUNT: inout STD_LOGIC_VECTOR(3 downto O ;
Encoder
21 Fip Flops process (CLK, RESET)
HEX2LED Convetter | B2gin
{2 Latches if RESET='1' then
22 Multplesers COUNT <= "D0D0";
Pulidonn elsif CLE='1' and CLK'event then
Pullp if CE='1' then
20 ReM if LOAD='1' then
22 Shift Registers COUNT <= DIN;
{21 State Machines else
{20 Tristate Buffers if DIR='1' then
{22 User Templates COUNT <= COUNT + 1;
else
COUNT <= COUNT - 1;
ena if;
ena if;
ena if;

ena if;
ena process;

Lot i






3. Copy the contents from the Counter template in the VHDL Synthesis Templates folder and paste them into counter.vhd between the begin and end behavioral statements.
4. Close the Language Templates window.
5. Cut the port definitions from the comment section of the counter.vhd file and paste them into the parentheses in the port declaration of the counter entity.  The port definitions are the following lines:

--     CLK: in STD_LOGIC;
--     RESET: in STD_LOGIC;
--     CE, LOAD, DIR: in STD_LOGIC;
--     DIN: in STD_LOGIC_VECTOR(3 downto 0);
--     COUNT: inout STD_LOGIC_VECTOR(3 downto 0);

6. Uncomment the above port definitions in your counter.vhd file by removing the dashes from the beginning  of each line.
7. Remove the semicolon that follows the COUNT port definition.

COUNT: inout STD_LOGIC_VECTOR(3 downto 0)

8. Save counter.vhd by selecting File ( Save.
Your Counter.vhd source should look like the following.

Part 1 Deliverables


1. Print the counter.vhd file
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Part 2: Top Level Schematic

This section demonstrates how to create a top-level schematic that contains instantiations of the counter module, and describes how to wire together the modules, add net names and buses to the wires, and add I/O markers to show where signals enter or exit the schematic.  This section of the tutorial introduces you to the Xilinx tool for creating and editing schematic diagrams, Engineering Capture System (ECS).

2.1 Creating a Schematic Symbol for the VHDL Module

To create a schematic symbol for the VHDL module:


1. In Project Navigator, in the Sources in Project window, select your counter module, counter.vhd.

2. In the Processes for Current Source window, click the + sign beside Design Entry Utilities and double-click the Create Schematic Symbol process.

Note: This places a schematic component entitled “counter” in the project library.

2.2
Creating a New Top-Level Schematic


To create a new top-level schematic, in Project Navigator:


1. Select Project ( New Source.
2. Select Schematic as the source type.
3. Type in the name “top”.
4. Click Next and then click Finish.

ECS is launched and a blank sheet opens in an ECS schematic window.  In ECS, you will create a schematic diagram from scratch.


2.3
Instantiating VHDL Modules

With a blank sheet open in ECS, instantiate two counter module symbols in the top-level schematic.


1. Select Add ( Symbol  or click the Add Symbol icon in the Tools toolbar.
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2. Select counter from the Symbols list in the Symbol tab (to the left of the screen).  Do not select any options from the Categories list.

3. Place two counters in the schematic.  Click the left mouse button to place a counter on the schematic where the cursor sits.

4. Press Esc to exit Add Symbol mode and restore your cursor.

Note: Adjust your view using the Zoom option (View ( Zoom ( In) and the scroll bars in ECS.

Your Schematic should look like the following diagram:
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2.4 Wiring the Schematic

When wiring the schematic symbols, some wires interconnect the modules and others are extended and left hanging.

1. To activate the drawing tool, select Add ( Wire or select the Add Wire icon from the Tools toolbar.
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2. To add a hanging wire or to extend the wire for clk, reset, ce, load, dir, din(3:0) and count(3:0):


a. Click and hold the mouse button at the vertex of a pin on the first counter module.

b. Drag the mouse to extend the wire to the desired length.

c. Release the mouse button at the location you want the wire to terminate.

Note:  Add hanging wires according to the diagram below


3. To connect the wires clk, reset, ce and load from the second schematic symbol to the extended wires in the first schematic symbol:


a. Click once at the vertex of a pin on the second counter module.

b. Double click anywhere on the destination wire of the first counter module.

Note: Connect the wires of the two counters according to the diagram below.


4. When finished wiring, press Esc to exit Add Wire mode.
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2.5
Adding Net Names to Wires

After wiring the schematic symbols, you are ready to add net names to the wires

1. Select Add ( Net Name  or click the Add Net Name icon from the Tools toolbar.
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Next, add the following six net names to the schematic: clock, reset, ce, load, dir1, and dir2.

2. To create and place a net name for each hanging wire:

a. Type the net name in the text box in the Options tab, located to the left of the screen.
Note: Leave the default options as Name the branch and Keep the name.

b. Place the cursor, which now displays the net name, at the end of the hanging wire.

c. Click the left mouse button.

With the six net names added, your schematic should look like the following diagram.
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2.6 Creating Buses

Using a similar procedure to adding net names, create buses for the two counter modules by adding bus name and size to the count and din wires.

1. Select Add( Net Names  or click the Add Net Name icon from the Tools toolbar.  Next, add the following four buses (name and size) to the schematic: count1(3:0), count2(3:0), din1(3:0), and din2(3:0).

2. To add buses:

a. Type the bus name and size in the text box; for example, din1(3:0).
Note: Leave the default options Name the branch and Keep the name.

b. Place the cursor, which now displays the bus name and size, at the end of the hanging bus.

c. Click the left mouse button.

3. Pres Esc to exit Add Net Name mode.
After adding the bus names to the counters, your schematic diagram should look like the following.
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2.7 Adding I/O Markers

Next, identify the polarity of each signal (represented by a hanging wire) in these two counters.  In this tutorial , you will add input and bidirectional signal markers to the schematic diagram.  The results are shown in the schematic diagram below.

To add I/O markers:

1. Select Add ( I/O Marker or click the Add I/O Marker icon from the Tools toolbar.
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2. Add input markers to the clock, reset, ce, load, dir1, and dir2 wires, and the din1(3:0) and din2(3:0) buses as follows:

a. Select the Add an input marker option in the Options tab.

b. Place the cursor, which now displays the input graphic, at the end of the counter input wire.

c. Click the left mouse button to add the marker.

The input graphic is added to the end of the wire, around the net r bus name.

Note: Click the cursor at the end of the hanging wire when adding the marker.  If you try to add a marker to any location other than the end point, an error message box appears.


3. Add bidirectional markers to the count wires as follows:

a. Select the Add a bidirectional marker option in the Options tab.

b. Place the cursor, which now displays a bidirectional graphic, at the end of the counter outputs.

c. Click the left mouse button to add the marker.


Your completed schematic should look like the following diagram.
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4. Save the schematic diagram using File ( Save.

5. Exit ECS.

2.9
Part 2 Deliverables:

1. Generate and print a schematic of the counter.

Part 3: Design Implementation

For this tutorial, design implementation covers two tasks: running the Implement Design process in Project Navigator, and viewing the resultant placed and routed design in Floorplanner.

Note: For more information about implementing a design, see ISE Help.  Select Help ( ISE Help Contents, expand either the FPGA or CPLD hierarchy in the left pane and expand the Implementing a Design hierarchy.

4.1 Running Implement Design

First, run all processes (Synthesis through Place & Route) associated with the counter.  To do so, run Implement Design on the schematic file:

1. Select top (top.sch) in the Sources in Project window.

2. Double-click Implement Design in the Processes for Current Source window.

This runs all processes.
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A check mark in the Processes for Current Source window denotes a process that was run successfully.  An exclamation mark indicates that the process was run and that there is a warning for the process.  More information about warnings can be obtained in the transcript window.

3.2
Viewing the Design in Floorplanner

Now, you can view the implemented design in Floorplanner.  Floorplanner is a graphical tool in which you can view and change the design hierarchy, floorplan, and perform design rule checks.

1. In Project Navigator, select top (top.sch) in the Sources in Project window.

2. In the Processes for Current Source window, click the + sign beside Implement Design and the + sign beside Place & Route.

3. Double-click View/Edit Placed Design (Floorplanner).
The Floorplanner tool is launched and displays the placement of the design for the project.

To view the implemented design results in a more meaningful way, you can display and zoom in on the input/output signals.

1. In the top.fnf Design Hierarchy window (View ( Hierarchy), select (highlight) the top-level hierarchy, “top(22 IOBs, 13 FGs, 8 CYS, 8 DFFs, 1 BUFG)”, to show the signals in the Placement window.

Note: Alternatively, you can draw a rectangle around the design area in the Placement window to show the signals.

2. Select View ( Zoom ( In or click the Zoom In icon. 
3. Verify that all the I/Os are accounted for by holding the cursor over each of the pads and reading the pad name in the lower left corner of the Floorplanner window.

Note: Alternatively, you can view isolated signals in the placement window by selecting individual signals from the list in the top.fnf Design hierarchy window.


The placement in Floorplanner should look like the following:
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When you have finished viewing the implemented design:

1. Save the Floorplanner design view using File ( Save.
This saves top.fnf and creates top.ucf.

2. Exit Floorplanner.

3.3
Part 3 Deliverables 

1. Generate and print a Floorplanner layout of the counter

Lab 4 Report

Create a short report describing your activities.  The report should include the simulation results, listings of our simulation files, and printouts of your results that verify the correctness of your simulations.  Discuss our observations and comment on the results.

Note:  the students can use their printing quota (credit) to print the results in the lab.  Or they can save the results as PS file and print them at home.
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