ECE349b - Introduction to VLSI 
Dr. W. Wang, Rizwan Mudassir
                         Lab 1&2:  Creating an INVERTER Schematic and layout
Lab 1: Creating an inverter schematic and schematic simulation

Step 1:

Type the following command from the UNIX prompt:

             startCds   –t  cmosp35
Step 2:
In the icfb window, select

                     File -> New -> Library
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Step 3:

In the New Library window, fill in the following: 

Name: mylib (or any other suitable name)

Technology File: select Attach to an existing techfile button  

       Select OK at the top of the New Library window.

Step 4:

        From the pop-up window, change the default Library to cmosp35.

Step 5:
  First a new cell for the schematic will be created.  In the icfb window, select 

          File -> New -> Cell view
Step 6:

            In the Create New File window, fill in the following:


Cell Name:  enter a name of your cell as INVERTER

View Name:  enter schematic

Tool:  select Composer-Schematic
            Click the OK button
Step 7:

           An instance of the pmos schematic will be placed from the cmosp35 library.  From the Schematic Editing window, select Add -> Instance

Step 8:

            In the Add Instance window, click browse, and choose the following:

Library:  cmosp35
Cell:  pfet
View:  symbol
              Then place the pmos transistor in the schematic window. 

Step 9:

            Add an nmos instance by choosing the following in the Add Instance window:

Library:  cmosp35
Cell:  nfet
View:  symbol
            Place the nmos transistor below the pmos transistor. 
Step 10:  

            Add a DC voltage source to power the inverter by choosing the following:

Library:  cmosp35
Cell:  vdc
View:  symbol
Name:  Vdc
DC voltage:  3.3 

             Place the voltage source in the schematic window.

Step 11:

            Add a ground by entering the following:

Library:  cmosp35
Cell:  tiedown
                    View:  symbol
             Place the ground in the schematic window.

Step 12:

            Add a capacitor load to the inverter output by entering the following:

Library:  cmosp35
Cell:  capacitor
View:  symbol
Name:  C1
Capacitance:  10f F
            Place the capacitor in the schematic window.

Step 13:

           Add a stimulus to the inverter input using a pulse voltage source by entering the   following:

Library: cmosp35
Cell:  vpulse
View: symbol
Name: Vpulse
V1 voltage:  0.0
V2 voltage:  3.3

            Place the pulse voltage source in the schematic window.

Step 14:

             From the Schematic window, select

             Add -> Wire (narrow)
Left click on the gate of pmos (the small red square), drag the mouse to the gate of nmos, left click again.  A wire connection between the gates is established.  Continue to make the wire connections for the rest of the inverter circuit as shown in the diagram below (Figure 1):
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Figure 1: Schematic of Inverter
Step 15:  

            Next we create the Vin and Vout pins to the schematic.  To add pin, select 

            Add -> Pin
           Type in the Pin Names: IN
          Choose direction: input
           Then place it on the wire where you want the pin.

Step 16:

                  Create another pin for Vout as follows:

                  Pin Name: OUT
                  Direction: output

                  Place it on the wire according to the above diagram.

Step 17:

            Check and Save your schematic.  There should be no errors (check in the icfb  window).

Step 18:
               Now SpectreS simulation can be setup to run a simulation on the inverter.

               Select Tools -> Analog Environment
Step 19:
              Select Setup -> Environment
              In the Include File, put in the following path:

/CMC/kits/cmosp35.4.3/models/B3V/icdspectre.init

              Click OK.

Step 20:
            From the Analog Environment window, select 
            Analyses -> Choose 

            Analysis: tran

            Stop time: 40n

            Turn on Enabled.

            Click Apply and OK.

Step 21:

            From the Analog Environment window, select 
           Outputs -> To Be Plotted -> Select On Schematic
Click on the wires connecting to IN and OUT pins in the schematic window.

In the Analog Environment window, you will see the selected wires, Vin and Vout indicated in the Outputs section.
Step 22:
          Select Outputs -> Save All, select all node voltages, and click OK.
Step 23:

            From Analog Environment window, select 
            Simulation -> Run

          The waveform window will pop up with the resulting waveforms when the simulation is finished.
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You should see that Vout is an inverted version of Vin.
Lab 2: Creating an inverter layout

(PART A): USING THE VIRTUOSO LAYOUT EDITOR TO CREATE A PMOS- TRANSISTOR
Step 1:

First a new cell for the schematic will be created.  In the icfb window, select 

File -> New -> Cell view
Step 6:
In the create new file window fill in the following: 

Library Name: click on this button to select from a list of possible libraries the library you created in the above steps (From example mylib) 

Cell Name: enter the name of your cell, for example, PMOS
View Name: enter Layout 

Tool: select Virtuoso 

       Click on the OK button.
Note: In your virtuoso window select options—Display( then change X-snap and Y-snap spacing to 0.05 then press OK
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Step 7:

Select the poly dg layer from the LSW window.

From the Virtuoso Editing window select Create -> Rectangle.

Draw a rectangle of poly dg layer of size 0.35 micron long x 3.5 wide micron.
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Step 8:

Select from the LSW window the pplus dg layer and create a rectangle of approximately 4 microns long and 2 microns wide overlapping the poly dg layer.
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Step 9:

Select the nwell dg layer from the LSW.  Create a rectangle of approximately 6.0 (long) and 7.0 microns wide and place it over the layers you have already drawn.
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Step 10:

Create a contact by obtaining an instance of the predefined cell con from the cmosp35.  To do this, select Create -> Instance from the Virtuoso Editing window.   In the Create Instance window click Browse, select wcells in the Library field, con as cell, place it at one end of the polysilicon gate.  Press ESC to stop creating instances of this cell.  
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Step 11:

Select from the LSW window the active dg layer and create a rectangle overlapping the pplus rectangle.
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Step 12:

Place two more con cells from the wcells library using the Create -> Instance menu.  These two contacts should be placed in the pplus area.  
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Step 13:

Select the nplus dg layer from the LSW window, and create a rectangle with this layer.  Place the nplus rectangle with one edge adjacent to the nwell of the transistor.  
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Step 14:

Select from the LSW window the active dg layer and create a rectangle overlapping the nplus substrate.

Step 15:

Place a contact at one end of the nplus substrate.

Step 16:

Select metal1 dg from the LSW window.  Create and place a rectangle connecting the contact you have just placed in the nplus substrate with one of the contacts in the pplus 
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diffusion.  Draw a rectangle of poly dg layer to cover the contact placed at the end of  polysilicon gate.
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Step 17: 
Create a symbolic pin from virtuoso editing window by Create(pin(select Display pin names(select display pin name option and change the height to 0.5, and then type vdd(input/output) in terminal name of the Create symbolic pin window. Place the pin on metal1 dg layer as shown in figure below.
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Step 18:

Save your work by selecting Design -> Save from layout editing window.  As a final check, perform a design rule check (DRC) from layout editing window by clicking Verify(DRC and then press OK.  There should be 0 errors reported in the CIW window.  This completes your pmos transistor.

Part B: USING THE VIRTUOSO LAYOUT EDITOR TO CREATE A NMOS    TRANSISTOR
Step 1:

Create a new cell

File -> New -> Cell view

Step 2:

In the create new file window fill in the following: 

Library Name: choose the same library name (From example mylib) 

Cell Name: enter the name of your cell, for example, NMOS
View Name: enter Layout 

Tool: select Virtuoso 

Click on the OK button.
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Step 3:

Select the poly dg layer from the LSW window.

From the Virtuoso Editing window select Create -> Rectangle.

Draw a rectangle of poly dg layer of size 0.35 micron long and 3.5 micron wide.
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Step 4:

Select from the LSW window the nplus dg layer and create a rectangle of approximately 4 microns long and 2 microns wide overlapping the poly dg layer.

Step 5:

Create a contact by obtaining an instance of the predefined cell con from the cmosp35.  To do this, select Create -> Instance from the Virtuoso Editing window.   In the Create Instance window click Browse, select wcells in the Library field, con as cell, place it at one end of the polysilicon gate.  Press ESC to stop creating instances of this cell. 
 Step 6:

Select from the LSW window the active dg layer and create a rectangle overlapping the nplus rectangle.
Step 7:

Place two more con cells from the wcells library using the Create -> Instance menu.  These two contacts should be placed in the nplus area.  

[image: image19.jpg]



Step 8:

Select the pplus dg layer from the LSW window, and create a rectangle with this layer.  Place the pplus substrate next to the nplus rectangle.

Step 9:

Select from the LSW window the active dg layer and create a rectangle overlapping the pplus substrate.

Step 10:

Place a contact at one end of the pplus substrate.

Step 11:
Select metal1 dg from the LSW window.  Create and place a rectangle connecting the contact you have just placed in the pplus substrate with one of the contacts in the nplus. Draw a rectangle of poly dg layer to cover the contact placed at the end of polysilicon gate.  
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Step 17: 

                   Create a symbolic pin from virtuoso editing window by Create(pin, and then type vss in terminal name of the Create symbolic pin window. Place the pin on metal1 dg layer as shown in figure above.
Step 18:

Save your work by selecting Design -> Save from layout editing window.  As a final check, perform a design rule check (DRC) from layout editing window by clicking Verify(DRC and then press OK.  There should be 0 errors reported in the CIW window.  This completes your nmos transistor.

PART C: CREATING AN INVERTER USING INSTANCES OF NMOS AND PMOS TRANSISTORS
Step 1:

Create a new cell

File -> New -> Cell view

Step 2:

In the create new file window fill in the following: 

Library Name: choose the same library name (From example mylib) 

Cell Name: enter the name of your cell, for example, INVERTER

View Name: enter Layout 

Tool: select Virtuoso 

Click on the OK button.

Step 3:

To add an instance of a previously created Cellview, select Create -> Instance from the Virtuoso Layout window.  In the Create Instance form which will appear click Browse, select Mylib (what ever name you have specified) in the Library field, PMOS as cell. Press ESC to stop creating instances of this cell. 

For example:

Library 
mylib

Cell

pmos

View

layout

Place the instance in the window.

Step 4:

Repeat the above step to create and place an instance of your NMOS cell.  Place this instance slightly below the pmos instance.  

Step 5:

Next, select the entire pmos and nmos instances by drawing a rectangle around them.  Then, select Edit -> Hierarchy -> Flatten(select Preserve pins from the Layout window and click OK in the Flatten popup window.
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Step 6:

Connect the two gates of the two transistors with a poly dg rectangle.  Place an instance of con in the middle of the poly rectangle just created.  Place a symbolic pin with terminal name IN and direction set to input and Pin Type metal1_T to define the input pin in this poly dg rectangle.  

Step 7:

Connect the two drains with metal1 dg.  Place a Symbolic pin with terminal name OUT and direction output and Pin Type as metal1_T inside this metal1 dg path connecting the two drains.

Step 8:

Save your design.

Step 9:

Perform a Design Rule Check and correct any errors if any.  

This completes your LAB 1 & LAB 2.
Lab Report:
Create a short report describing your activities and discuss your observations and comment on the results.

The report should include the following: 

PART 1:  Inverter Schematics + Simulation

1) Value of the load Capacitance, CL =  ……pF. 

2) Find the time delay of the inverter, td (schematic) = ………  
PART 2: Layout of NMOS Transistor

1)  Area of the Layout of the NMOS =  ……..m2 

2) Gate Width and Length : W = ……m,   L=…….m
3) List the errors (if any) reported in the CIW (icfb) Window, after the 1st DRC check  :………………………………………..



    …………………………………………



                   …………………………………………
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